Back to overview
Resolved
Iridium Backend Services - Partial Outage
Jul 21, 2026 at 12:00am UTC
Affected services
Adroit Platform Backend Services
Resolved
Jul 24, 2026 at 3:30am UTC
All services returned to normal operation.
Affected services
Created
Jul 21, 2026 at 12:00am UTC
Some Adroit solutions using the Iridium network / backend services may be experiencing disruptions at this time.
Affected services